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Welcome

Avenza welcomes you to mapmaking in the 21st century!

Combined with Adobe Illustrator, MAPublisher has revolutionized the art of mapmaking by allowing spatial data
to be used to create maps inside a vector graphics program. MAPublisher allows all your cartographic tasks to be
performed where they should be done; in a powerful graphics environment.

MAPublisher 9.1 improves on the already powerful tools of previous versions by adding additional file support,
additional tools and improvements to existing tools.

This Quick Start Guide assumes that you are familiar with Adobe Illustrator CS5 or CS6 and have at least a basic
understanding of geographic information systems (GIS) terminology and concepts. The exercises in this guide are
meant to help you quickly start working with the basics of MAPublisher. Not all MAPublisher tools are explained
in this document. To gain a better understanding of all the features and tools MAPublisher has to offer, use this in
conjunction with the MAPublisher 9.1 User Guide and MAPublisher 9 Tutorial Guide.

By following these tutorials you will learn how to create maps using MAPublisher tools in Adobe Illustrator.

This guide covers the steps necessary to build a map and perform fundamental cartographic and GIS tasks. It is
recommended to start from the beginning and work your way through the exercises. However, it is also possible to
start at any of the exercises.

Quick Start Guide Data

All the exercises in this guide will use GIS data supplied in the MAPublisher installer. After installation, you can find
the Quick Start Guide data in the following location on your hard drive:

Windows XP
C:\Documents and Settings\All Users\Shared Documents\Avenza\MAPublisher 9\Quick Start Guide & Data\Quick Start Data

Windows Vista and Windows 7
C:\Users\Public\Documents\Avenza\MAPublisher 9\Quick Start Guide & Data\Quick Start Data

Note: This data can be accessed through the Windows Start menu Avenza program group.

Mac0SX
/Applications/Avenza/MAPublisher 9.1/MAPublisher Tutorials/Quick Start Guide & Data/Quick Start Data

You are encouraged to experiment with your own data to gain additional experience with MAPublisher tools,
functions and features.
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1 Getting Started

1.1 Purpose

The purpose of this exercise is to create a simple map of downtown Vancouver, B.C., Canada and to export it as a
web map for online presentation. A 600 px by 600 px sized Adobe Illustrator document will be used and optimized
to be displayed in a web browser.

The web map will be used to represent restaurants, hotels, and points of interests in downtown Vancouver, and will
display information such as their address, phone number, and Web site. In addition, some pictures and logos will be
inserted into callouts to catch the interest of readers.

The necessary GIS data (vector and raster), additional information, and web images are included with every
installation of MAPubilsher. This Quick Start Guide will guide you through a typical MAPublisher work flow of map
creation—from data import to final export to web. It can be used as a base to build up your own work flows for

cartographic production.

1.2 Know your data

The Quick Start Data folder contains vector, raster, and additional GIS files for use with this guide:

Name (main file) Format Type Description Coordinate System

\Quick Start Data\Vector Files\Geodetic Data

Land.shp Esri Shapefile Area Land boundaries Geodetic WGS84

Parks.shp Esri Shapefile Area Park areas Geodetic WGS84

River.shp Esri Shapefile Line Rivers Geodetic WGS84

Water.shp Esri Shapefile Area Water bodies on land | Geodetic WGS84

\Quick Start Data\Vector Files\Projected Data

Hotels.shp Esri Shapefile Point Hotels Projected NAD 83/ UTM 10N
Restaurants.shp Esri Shapefile Point Restaurants Projected NAD 83/ UTM 10N
Neighbourhoods.mif MaplInfo MIF/MID | Point Neighbourhoods Projected NAD 83/ UTM 10N
Boundary.mif Maplinfo MIF/MID | Area Map extent Projected NAD 83/ UTM 10N
Roads.tab Maplnfo TAB Line Road network Projected NAD 83 /UTM 10N
\Quick Start Data\Raster Files

VancouverDowntown.tif | GeoTIFF Raster Satellite image Projected NAD 83 / UTM 10N
\Quick Start Data\Additional Files

PointsOfinterest.csv Text (csv) Attribute | Points of interest Geodetic WGS84
RoadCategory.dbf DBF (Excel) Attribute | Road categories N/A

The roads, rivers, land, and water information were extracted from the Avenza MAPdataCanada data library
and the parks, hotels, restaurants, neighbourhood, and points of interest were manually digitized. The
VancouverDowntown.tif image was acquired and georeferenced by Avenza Systems using Geographic Imager for

Adobe Photoshop.
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Web Images
The two subfolders containing images used during the web tagging process are:

«  The PointsOfinterest subfolder contains images referred to in attribute fields image and logo_image of
the PointsOflnterest.csv table

«  The Restaurants subfolder contains images referred to in attribute fields PICTURET and PICTURE2 of
Restaurants.shp file

Quick Start Template

The Quick Start Template is an Adobe Illustrator file that contains information and data needed by the user to complete
this guide. Included in the template file are three sets of styles that will be used during the styling of the map:

«  Graphic styles library (used for line and area features)
«  Symbol library (used for symbolizing points)
«  Character style library (used for labeling)

Also included in the Quick Start Template are predefined MAP Theme Stylesheets, MAP Selections and layers. If
more information on a particular feature of MAPublisher is needed, please refer to the MAPublisher 9.1 User Guide
or the MAPublisher 9.1 Tutorial Guide.

1. In Adobe lllustrator, open Quick Start Template.ait located in the \Quick Start Guide & Data folder
(the .ait extension is an Adobe lllustrator Template file).

LA Y Bl

Eslenn

A blank artboard opens with a 600 px by 600 px dimension. The template includes predefined styles, symbols and
layers needed to complete the Quick Start exercises. The size of the document here determines the final size of the
web map viewed in a browser.

Note: Customize the Adobe lllustrator workspace to make it easier to access the panels. It may look different than
the image above if MAPublisher is opened for the first time. Read Customizing the workspace in the Adobe
lllustrator help guide for more information.
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2 Import GIS Vector Data

2.1 Import data using Simple Import

1. From the MAPublisher toolbar, click the Simple Import button . Alternatively, in the Adobe lllustrator menu,
choose File > Import MAP Data > Simple.

2. Choose Esri Shapefile from the Format drop-down list and click the Browse button.
3. Navigate to \Quick Start Data\Vector Files\Geodetic Data and select all four files (Land.shp, Parks.shp, River.shp and
Water.shp) and click Open.

The four files are listed in the Dataset box in the Simple Import dialog box.

Simple Import
Format: [&n Shapefile [*.shp] V] Settings...
Dataset: DataQuick Start Datz iector Fles\Geodetic DataWatershp
Encoding: [Sysbem v]
Source Coordinate System:
Same as: A

Note: The Source Coordinate System displays WGS84. This is stored in the shapefile projection format (.prj file).
MAPublisher can import multiple files at once using Simple Import as long as the file format and coordinate
system are the same.

4. Make sure the dialog box matches the one above and click OK.
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Notice that in the Adobe lllustrator Layers panel, there are four new layers called River_line, Water_area,
Land_area and Parks_area. In the MAP Views panel , there is a new MAP View also containing the layers.

5. In the MAP Views panel, double-click the new MAP View to edit it. Change the name to First MAP View and click
OK to accept the change and close the MAP View editor dialog box.

MAPublisher 9.1 Quick Start Guide 7
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2.2 Import data using Advanced Import

You'll be adding additional vector data of different formats using Advanced Import.

1. From the MAPublisher toolbar, click the Advanced Import button . Alternatively, in the Adobe Illustrator menu,
choose File > Import MAP Data > Advanced.

2. Click Add to open the Add dialog box and if necessary, choose Esri Shapefile from the Format drop-down list. Click
Browse, navigate to \Quick Start Data\Vector Files\Projected Data, select Hotels.shp and Restaurants.shp, click Open
and then OK.

3. Again, in the Advanced Import dialog box, click Add and choose Maplnfo Interchange Format from the Format
drop-down list. Click Browse, select Boundary.mif and Neighbourhoods.mif, click Open and then OK.

4. Finally, click Add, and choose Maplinfo Table from the Format drop-down list. Click Browse button to open the data
source browser, select Roads.tab, click Open and then OK.

Use the vertical scroll bar to view that all the data layers are present. MAPublisher automatically detects that the
data has a NAD83 /UTM zone 10N coordinate system and displays the information below.

Advanced Import

Coordinate System Data Source Features oK
1| NADS3 / UTM zone 10N [ Hotels.shp 10
2 NADS83/UTM zone 10N Restaurants.shp 12
3 NAD&3 /UTM zone 10N [I] Boundary.mif 1
4 NAD&3 /UTM zone 10N [I] Neighbourhoods.mif 7
5 MAD&3 /UTM zone 10N [] Roads.tab 194
add.. | [ Remove |[ Edit. |

Destination MAP View:

@ New based on: Hotels ~ | Coordinate system: MADS3 /UTM zone 10M
Page anchors: (0 px,0 px)
() Use existing: @ Land visual scale: 1:9518.071426
Map anchors: (489807.4093, 5458040.7502)
[C] Auto-scale Map unit: Meter
Map angle: 0

©) Create new: Editor...

5. Inthe Destination MAP View section, leave the New based on option as the default and click OK to accept the
changes and to close the Advanced Import dialog box.

Note: The New based on option bases a new destination MAP View on the coordinate system information listed in
the drop-down list. The Use existing option chooses an existing MAP View as a destination to where this data

is placed.

8 MAPublisher 9.1 Quick Start Guide
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Notice that five new layers are added in the Adobe lllustrator Layers panel: Hotels_point, Boundary_area,
Neighbourhoods_point, Restaurants_point, and Roads_line. You may have to zoom out to see its entirety. In the
MAP Views panel, there is a new MAP View (by default called Hotels) containing the added layers.

In the MAP Views panel, double-click the new MAP View to edit it. Change the name to Vancouver Downtown. Click
OK to close the MAP View editor dialog box.

The layers in the two MAP Views are not matching because they are based on two different coordinate systems
and two different scales. Tutorial 3 will provide steps to reproject all the layers into the same coordinate system.
Next, you'll import more data.

Import point data

From the MAPublisher toolbar, click the Simple Import button .

Choose Delimited XY Text Data from the Format drop-down list. Click the Browse button, navigate to

\Quick Start Data\Additional Files, select PointsOfInterest.csv and click Open.

The Settings dialog box appears. Under Coordinate Format, choose Decimal Degrees (D+[.d*]) in the Format
drop-down list.

Make sure that the Use first line as a header option is checked (because the first line in the text file contains
column headings). This option is checked if it is automatically detected.

Under Coordinate Columns, choose Longitude: -123.127416 in the Longitude drop-down list. In the Latitude
drop-down list, choose Latitude: 49.299093.

MAPublisher 9.1 Quick Start Guide
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Leave the Specify Schema settings as their default. These options allow you to customize the schema for each
attribute column. More information is available in the MAPublisher 9 User Guide.

Settings

Coordinate Format:
Format: [Daamal degrees (D+[.d*]) V]

Decimal degrees, with optional direction indicator.
Examples:
7.5444W, 54.977M | -79,44

Motation: items in [ ] are optional, '* means zero or more digits and '+ means
one or more digits. Direction can be indicated with -, 'N', or "W'".

Coordinate Columns:

Longitude: [Longm.lde: -123,127416 X2 ]

Latitude: Latitude: 49.299093 -]

Use first line as a header (detected)

Specify Schema:
-
0 :

6. Click OK to accept the settings.
Text files do not hold information about the coordinate system so it must be specified.

7. In the Source Coordinate System section, check the Same As option box and choose First MAP View in the
drop-down list.

Simple Import
Format: [Del\m\ted XY Text Data [*.csv *.tsv *.bxt] 'l l Settings... ] [ oK ]
Dataset:  Data\Quick Start Data\Additional Files\PointsOfinterest.csv
Encoding: [Unicode, 8-bit (UTF-8) ~|

Source Coordinate System:

WGS 84 From File...

Same as: [@ First MAP View -

8. Click OK to continue with the import.

10 MAPublisher 9.1 Quick Start Guide
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9. Since the coordinate system was chosen to be the same as First MAP View, select Add to: First MAP View under the
Destination MAP View area.

Matching MAP View Found

Your data matches one or more MAP Views found in the EI
document. Please select a destination MAP View.

Cancel
Destination MAP View:
@ Add to: [ B First MAP View - ]

[ Resize MAP View to fit

() Fit to page based on new MAF View

10. Click OK to add the points of interest to the First MAP View.

~ (@ First MAP View
17| PointsOfInterest_point
L |River_line

Land_area
[A]Parks_area
|Al water_area
~ @ Vancouver Downtown

988606

DiDE| DBPRED

@
#
&
h
&
Eh

MAP Viey

|

v|viv|w|[w|w

o
(o]
Restaurants_paint Q
o]
o
(e]

In the Adobe lllustrator Layers panel, a new layer called PointsOfInterest_point is added. It is also contained in
the First MAP View in the MAP Views panel. You'll reproject the data from the First MAP View to the Vancouver
Downtown MAP View in the next tutorial.

11. Save the document as Vancouver Downtown.ai to the Quick Start Guide & Data directory. Leave all save options as
the default.

MAPublisher 9.1 Quick Start Guide 1
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3 Reproject and scale

Continue working with your map or open Vancouver Downtown 3.ai.
3.1 Reproject all layers to NAD83 / UTM Zone 10N

1. Inthe MAP Views panel, select all the layers contained in First MAP View (Land_area, Parks_area,
PointsOfinterest_point, River_line and Water_area).

2. Click the Switch MAP View button at the bottom of the MAP Views panel and click Switch to “Vancouver Downtown”.

All layers are moved into the other MAP View, Vancouver Downtown. In the process of switching, the data is
transformed to the NAD83 /UTM zone 10N coordinate system. All the data is now in the same coordinate system
and aligns correctly.

MAP Views @ First MAP Vi
rs iew
~ B First MAP View ~ (@& vancouver Downtown
: B % :;nmiz"mmmm e |0 | Hotels_point
= = .
i - P paint
L2 ] | A [Land_area I8l .
= = [AlParic_area L= @ P PointsOfInterest_point
| |Parks T Restaurants_poin
® |0 [A]Water_area < o = ans_point
~ @ vancouver Downtown > = o [L |River_line
® (0O D [Hotels_point ® D Ll sz e
E-3 O I’ |Restaurants_point -] n] | A|Boundary_area
= O | Nei ;_point L) O A |Land_area
2 MAP Views %, @a,. Lo Al |A|Parks_area
Bl e (- ) A Water_area
» Z MNon-MAP Layers
@  Switch to "Vancouver Downtown” 2 MAP Views % OB' f' % —

3. Inthe MAP Views panel, select First MAP View and click the Delete button on the lower right corner to remove it
(this MAP View is not needed for the remainder of the exercise).

12 MAPublisher 9.1 Quick Start Guide
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3.2 Scale and edit MAP View

. In the MAP Views panel, double-click the Vancouver Downtown MAP View.
2. Inthe MAP View editor dialog box, choose Thumbnails & Boxes in the Preview drop-down list to see a preview of
the map document.
3. Inthe Scale box, type 22100 to achieve a scale of 1:22,100.
In the Quick alignment tab, click the top-center position in the page alignment grid.

Edit "Vancouver Dewrtawn®
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5. Click OK to accept the settings and close the MAP View editor dialog box.

The layers are scaled and centered to fit the top of the page. The chosen scale is appropriate to fit the data
within the artboard. It needs a few more datasets that you'll add in the next section.

6. If necessary, save your Adobe lllustrator file.
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4 Join Table to MAP Attributes

Continue working with your map or open Vancouver Downtown 4.ai.

1. Inthe Adobe Illustrator Layers panel, click the target button (circle to the right of the layer name) to select all art
on the Roads_line layer.

2. From the MAPublisher toolbar, click the MAP Attributes button . Alternatively, choose Window > MAPublisher >
MAP Attributes. In the panel, click the FULL_NAME column title to sort it.

MAP Attributes

Layer: | D] Roads_lne (194lines seiected) =] =
[5IFULL_RAME

1 [IstAveE

2 |lstAveW

3 |1st Ave W

4 |1st Ave W

5 |2nd Ave W

6 |Abbott St

7 | Alberni St

8 | Alexander St

194lines selected EE Sfix FE

There is only one attribute column called FULL_NAME. The [l icon beside the column name designates it as a
String attribute type. Scroll down the table to see the other entries.

3. With the Roads_line artwork still selected, click the Join Table button = .
In the Join Table dialog box, click Browse and navigate to \Quick Start Data\Additional Files, select
Road(ategory.dbf, and click OK. Then choose the following settings (keeping all other options as default):
+ Source Matching Column: ROADNAME
« Destination Matching Column: FULL_NAME

o Tabe

= ﬁ
Data e Pl (ASCL, Exves, S, 0] - MAP Attributes

Cance
Dutnume: At Meafloedatogory b Laver: | L] Roads_line {194 ines selected) |~]
2 e ks [SIFULL_AAME  [[TJCATEGCRY
e 1 |IstAveE 3
2 [1stAveW 3
3 |LstAveW 3
o : 4 [1stAveW 3
: > 5 |2nd AveW 2
5 | Abbott St 3
e 7| AlbemniSt 3
S S s e I 5 |Alexander St 3
Wby ok LSRN INE 9 | Alvin Narod Me. El
10| Anderson St 3
T sl et walkiog 194 ines selected E S BE .
i matcheng cobuen $am source -

Note: In order to successfully join a table, both the MAP Layer and the data table must share at least one common
attribute column with matching values.

5. Make sure the dialog box matches above and click OK. Notice that a new attributes called CATEGORY is added
to the Roads_line table. If necessary, sort the columns to see the same results above.

6. If necessary, save your Adobe lllustrator file.

14 MAPublisher 9.1 Quick Start Guide
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5 Styling and MAP Themes

Continue working with your map or open Vancouver Downtown 5.ai.
5.1 Organize layers

1. Rearrange the layer order in the Adobe lllustrator Layers panel as follows (click and drag the layers in the panel):

i

v

Boundary_ares
Legend
Scale Bar

v

MNeighbourhoods_point
MNeighbourhoods Labels
PaintsGfinterest_paint

Hotels_point

Restaurants_paint
Rozds_line
River_line

il

SO

¥ ¥ ¥ v rvvvyvvw

6 666 6 6006060606066 -6
@ o olo|o|@o|o|jo|jo|o|o|o|o

5.2 Apply graphic styles to areas manually
1. In the Adobe Illustrator main menu, choose Window > Graphic Styles to open the Graphic Styles panel.

OO =

i % W@

2. Inthe Adobe lllustrator Layers panel, select all art on the Boundary_area layer by clicking the target button.

3. Click the Boundary graphic style to apply it to all selected art on Boundary_area (hover over the graphic style
thumbnail to see the name of it).

Select all art on the Water_area layer and apply the Lake graphic style.
Select all art on the Parks_area layer and apply the Parks graphic style.
Select all art on the Land_area layer and apply the Land graphic style.

o s

Also notice the three additional graphic styles for the roads called Roads-Cat1, Roads-Cat2 and Roads-Cat3.
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2.

5.3 Apply Stylesheet MAP Theme to line layer

1.

In the MAPublisher toolbar, click the MAP Themes button .

MAP Themes

Roads

& symbols

2 MAP Themes

=
w

v ok

The Quick Start template file contains two existing Stylesheet MAP Themes: Roads and Symbols. These themes
were created for your convenience, but they do not contain any rules yet to style the map. You'll create some

rules to style the Roads and Symbols layers. For more information on creating and using MAP Themes, refer to
the MAPublisher Tutorial Guide or the MAPublisher User Guide.

In the MAP Themes panel, double-click the Roads Stylesheet MAP Theme.

Edit Styfesheet Theme

Theme name: foade

() torenss >

Ao aonign: Mg imooted ke vl be auto mesaned to S stdestecl
Rutes: &)

-

Apshy Visusl Properties

Click the = Layers button to bagin

[oetaat

: Rasmtif

L o R P,

3. Click the Layers button to add the Roads Layer so rules can be generated for it. In the Select Layers dialog box,

16

click the check box for the Roads layer and click OK.

Sedect Layers
Layer Name Selected | [
16 Roads line I | ———
B Frver fine [
[ seeam | [ oew |
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Notice that the Layer status lists the Roads layer. You'll now have to add generate rules for it.
Click the Batch Generate Rules button.

In the Batch Generate Rules dialog box, choose CATEGORY from the Attribute drop-down list and click the Load
button. Under Data Classification, choose Unique Values from the Method drop-down list.

Batch Generste Rules.

ul

Data Classfication:

Saurces 1949 vakue(s) {3 urvue] from CATEGORY

Methort: [Lrscue ek -
Eapresin

1 CATEGORY =1

2 CATEGORY = 2

3 CATEGORY = §

Setswoke B o1 | [l serdl: e ot | ]
S

Set stoke coachy: : St Memeitr: 0% o [l

Sat gtk wisght: 58t npadity . E

Notice that there are three categories for roads. The three graphic styles for roads, as seen in the previous
exercise, can be assigned to these rules.

Under Visual Property Assignment, click the check box beside Set style, then click the Select button.

In the Select Styles dialog box, select Roads-Cat1and click the right-arrow button to move it into the Selected
column. Repeat for Roads-Cat2 and Roads-Cat3. Then click OK.

Select Styles
Unselected: Selected:
L] [Default] Roads-Cat1 £S
& Poris Roads-Cat 2 =
[] Land Roads-Cat 3
[ Boundary
Ocean
0
4
6 available style(s) 3 selected style(s)
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W caemRr v = 1 @&
Expression: CATEGORY = 1
Apply Visual Properties:
4] ste: [ messacat 1 =) (]
DS [rene) -l@
Cstoke opaary: =~ — e (@)
DOiseoevegnts [toge 2] ®)
On: ([ e 1A
I Fl ouaity: AT T o .-i' i“‘“"" ,._ @
1 el Ty &
5l Gpadiy e R A o i

9. The new rules are now listed. Click Apply to apply the rules to the map.
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The road lines styled properly according to the rules defined in the MAP Themes.

5.4 Apply Stylesheet MAP Theme to point layers

1. In the MAP Themes panel, double-click the Symbols Stylesheet MAP Theme.

2. Click the Layers button and click the Selected check boxes for the PointsOflnterest_point, Hotels_point, and

Restaurants_point layers.

Edit Stylesheet Theme

Theme name:  Symbols

Layers: PaintsOflnterest_paint, Hotels_paint, Restaurants_point

Visual properties: Reset i no ruie qualfies.

@ Batch Generate Rules...| | Batch Edit Rules... =

Auto-assign: Noimported lavers will be auto-assigned to this stylesheet.

Rules:

+ CATEGORY:
+ CATEGORY:
+ CATEGORY:
+# CATEGORY: "
+ CATEGORY:
+ CATEGORY:
+ CATEGORY:
+ CATEGORY:

"aquarium”
“gallery”
"hotel”

infermation”

"museum”
“restaurant”
"science’
"theatre”

MName:
Stop applying rules if art qualifies for this rule
Da not apply this rule
Expression:
@ [
Empty expression. In position: 0
Apply Visual Properties:
Graphicstyle: [ [] Default] ™
Symbol: @ [MAPublisher Default Symbol] fra
Rotation: 0.00 . Angle is relative to MAP View fe
Scale: 100% fa
Opacity: 100% fo

In the Edit Stylesheet Theme, the expression and symbol styles are all defined.

3. Click each rule to see its expression and symbol properties.

Notice how the science and theatre categories have the wrong symbol assigned to them (both are assigned a

hotel symbol).
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4. Correct the errors and choose the appropriate symbol for the science and theatre categories. Assign the science
category the science centre symbol and the theatre category the museum and point of interest symbol.

Edit Stylesheet Theme

Theme name:  Symbols Visual properties: Reset if na rule qualifies.

Layers: PointsOfinterest_point, Hotels_point, Restaurants_paint @ Batch Generate Ru\esm] [j Batch EdltRu\es.‘.] P
Auto : Noimported lavers wil be auto-assioned to this styleshest,
uto-assign: Mo impor layers will be auto-assigne: lis stylesheed
Rules: =)
[a] [« CaTEGORY: "aquarium" Name: CATEGORY: “theatre™
| ¥ CATEGORY: "gallery" Stop applying rules if art qualifies for this rule
' CATEGORY: "hotel” [T Do not apply this ruie
« CATEGORY: "information’ B
« CATEGORY: "museum”
S| CATEGORY - theatre v |fu
« CATEGORY: "restaurant” [Z] (7o
« CATEGORY: "science’ -
«f CATEGORY: "theatre’ Expression: CATEGORY = “theatre™
Apply Visual Properties:
[ Graphicstyle: | [, ] [Default] =
Symbol: [ 7 museum and point of nterest -
[T Rotation: 0.00 B Angle is relative to MAP View
] Scale: 00% |
[ Opacity: 100% 5

The three point layers used above can be used in a single Stylesheet MAP Theme because they share an
identical attribute structure. You'll also edit all the rules at the same time to change the visual scale.

5. Click the Batch Edit Rules button. In the Batch Edit Rules dialog box, click the check box beside Set scale and
type 60% into both boxes. Hint: set the scale in the box on the right before the left. Click OK.

Bateh Edit Rules
Adfected rules: Changes: | o
" CATEGURY: "squarurm’™ Marme Seale | ps ]

" CATEGURY: “gallery”
w" CATEGURY: “holel

o CATEGORY: “mfcarnstio
" CATEGORY: “musewsm”
+F CATEGORY: “restaurant’
" CATEGORY: “science”
F CATEGORY: “theatre™

| CATEGORY: “squarur™  60%

CATEGORY: “gallery” (9

|CATEGORY: “hatel™ BO%,
EF&IFGOP.Y: infoamation” 80%,
;fa\'lFGORY: “museum”  BO%,
EF&IFGOP.Y: “restaurant”  80%,
;fa\'lFGORY: “science” BO%,

| CATEGORY: “theatre” 0%

2 n, '. { -

Gvernrile Visual Properlies:
Set atyle: 7] Setscale: whe (5t sow (3] O Reverse [
Setrotaton: Sexgrachicstle:  From ket of 0 stviels Select |i|
Setopacity:

6. In the Edit Stylesheet Theme dialog box, notice that the scale for each rule is now set to 60%. Click OK to
confirm the edits.
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7. Inthe MAP Themes panel, click Symbols to select it, then click the Apply MAP Theme button.

MAP Themes

(%] roads
& Symbols

2MAP Themes =|voh @

8. If necessary, save your Adobe lllustrator file.
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6 Labeling

Continue working with your map or open Vancouver Downtown 6.ai.

1. In the MAP Views panel, under [Non-MAP layers], click and drag the Neighbourhood Labels layer to the
Vancouver Downtown MAP View.

2. Inthe Undefined Layer dialog box that appears, specify the MAP layer Feature type to Text, and click OK.

Undefined Layer - Neighbourhoods Labels

Feature type: [ Text - ] [ 0K J
Advanced:

[] Base attribute schema on: Hotels_point - Apply to all
Check this option o inherit the awibute stucure from the spacfied layer.

3. Inthe Adobe lllustrator Layers panel, click the target button next to the Neighbourhoods_point layer title to
select all the art on that layer.
In the MAPublisher toolbar, click the Label Features button |§|

5. In the Attribute column drop-down list, choose AreaName. In the Target column, choose Neighbourhoods Labels, and
in the Style column, choose Labels_Style.

6. In the Point Settings tab, set the Label position to Bottom Middle and click OK.

Label Fratuses

el =
Layer Attribute Target e | —J
1 [¥] Nrighbauthonds_paint % AreaName [ Neighbouthonds Labels == Labels_Style |
[ aren settngs | [ Lne Setings Point Settings
Label posibon: [Botion Mdde -

Label

Labels curve with bnes of bbthude
L sourading shyle labrels

7. Inthe Adobe lllustrator Layers panel, turn off the Neighbourhoods_point layer as it will not be needed for the
rest of the exercise.
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The text from the AreaName attribute of the Neighbourhoods_point layer is placed on the map, in the text layer
Neighbourhood Labels.

8. If necessary, save your Adobe Illustrator file.
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7/ Import GIS Raster Data

Continue working with your map or open Vancouver Downtown 7.ai.

1. From the MAPublisher toolbar, click the Simple Import button. Choose Image in the Format drop-down list and
click the Browse button. Navigate to \Quick Start Data\Raster Files, select VancouverDowntown.tif and click Open.

Simple Import
Format: [Image [*.png *.jpg =tif =.gif =.jp2 *.psd *.pdd *.bmp] '] [ Settings... ] [ oK ]
Dataset:  Data\Quick Start Dat Raster Fles WVancouverDowntawn. bF
Encoding: |Unicode, 5-bit (LUTF-5) -

Source Coordinate System:
[ same as: | @ vancouver Downtown -

2. Click OK to import the image. In the Matching MAP View Found dialog box, make sure the Add to: Vancouver
Downtown MAP View is chosen and click OK.

m]
® |D
® D
® DO
® |D
® |D
® D
J | ® m] T | vancouverDowntown_image
~ [Aton-Map Layers
) [image

,_.
=
]
7
2

Layers
® > couverDawntown_imsge om
® » [ | Boundary arez o
® [ ] Legend o
® [ | e Bar o
® » [ | nefahbourhoods_peint o
® » [ | neihbourhoods Labsls o
® > PointsOfinterast_point o
® » [ ] Hoteks point o
® » = :_paint o
® > : Roads_line o
15 Layers. P E owmag &

The image gets placed on the artboard but it is at the top of the list and hides all the other layers.

3. Inthe Layers panel, click and drag the VancouverDowntown_image layer to the bottom of the list.
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You'll add some transparency to the Land layer so that the raster can still be seen.

4. Select all objects on the Land_area layer. Open the Transparency panel and change the opacity to 80%.

5. If necessary, save your Adobe lllustrator file.

MAPublisher 9.1 Quick Start Guide | 25
7 Import GIS Raster Data



8 Legend and Scale Bar

Continue working with your map or open Vancouver Downtown 8.ai.
8.1 Create alegend

1. In the MAP Views panel, under Non-MAP layers, click and drag the Legend layer to the Vancouver Downtown MAP
View. In the Undefined Layer dialog box that appears, set the MAP layer Feature Type to Legend and click OK.

2. Inthe MAP Themes panel, select Symbols and click the Create Legend button at the bottom.

MAFP Themes

=
Roads

S Symbols

2 MAP Themes

vt

3. A message states there are no legend entries in the stylesheet and asks if you want to create a default legend.
Click Create default legend. The Create Stylesheet Legend dialog box opens.

Create Styleshest Legend

Output Layer: | [ Legend ~
Legend Entries | Legend key Options | Tite | Border
2 [CATEGORY: squarum’ Doty rame:

CATEGORY: "gallery”
CATEGORY: "hotel"
CATEGORY: "information”
CATEGORY: "museum”
CATEGORY: "restaurant”
CATEGORY: "science’
CATEGORY: "theatre”

v
Display expression:

Preview:

n CATEGORY: "aquarium”
[ carecory: “galiery~
CATEGORY: "hotel"

CATEGORY: "information™
[iil] cATEGORY: "museum™
[[)carecory: “restaurant~
CATEGORY: "science™
[iiT] cATEGORY: "theatre™

Preview quality: [Medum Show actual size

The Create Stylesheet Legend dialog box appears. A preview shows what the legend may look like. You'll change
several options to make a nicer looking legend.

Since the "theatre", "museum" and "gallery" have the same symbol to represent it, you'll remove two of them
and leave only one to represent them as a point of interest.
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4. Inthe Legend Entries tab, select CATEGORY: "museum" in the entries list and click the Remove button. Also,
remove the CATEGORY: "theatre" entry.

5. Change the display name of each entry in the Display name box. Select the CATEGORY: "gallery" entry and
rename it to Point of Interest. Rename the remaining entries like so:

Display name:

Science

Display expression:

CATEGORY = "science”™

Legend Entries | Legend Key Options | Tide | Border |
[a] [Aquarium

Point of Interest
T Hotel

Information

Restaurant

Science

6. Inthe Legend Key Options tab, change the size of the icon to 15.00 px by 15.00 px. Change the Space between

entries to 5.00 px

Legend Eniries | Legend Key Options | Tite | Border

Include name:
[ indude expression: [l Arial Black, 12.00 pt
Include ican:

W zrial Black, 12.00 ot

15.00px 5] x 150

[T Use actual size

Columns: 1 =

Alignment:

Space betweenentries: |[Fillpx [+

0 px

:

7. Inthe Additional Options, click the Draw border option to uncheck it.

| Legend Entries | Legend Key Options | Title | Sorder |

| stroke: | [l slack
Fill: /] Nene]

Margin: |5.00 px

-/l
-

@ [100%[2] = | Loopt

®) [100% =

8. Click the Create button to finish and place the legend on the document.

By default, the legend is positioned at the centre of the map on the Legend layer.
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9. Position the legend to the white space beneath the map.

|

v

[ Aquarium

Paint of Interest

[ | Hotel

i} Information
[} Restaurant
Ed Science

Note: The icons and text in the legend are grouped together.

8.2 Create a scale bar

1. Inthe MAP Views panel, under Non-MAP layers, click and drag the Scale Bar layer to the Vancouver Downtown
MAP View. In the Undefined Layer dialog box that appears, set the MAP layer Feature Type to Legend and click OK.

2. With the Scale Bar layer selected, click the Scale Bar button on the MAPublisher toolbar ki . In the Scale Bar
dialog box, expand the Advanced section and make sure your settings match the following and click OK.

Interval: 200 ——

Number of labeled intervals: 5

Change text to Arial Regular,
10.00 pt

Display scale value, show
above, align center

Display units to right of last
interval label

Scale Bar

- Scale 122,100
0 200 400 600 800 1,000 Meters

nits: fros - s
e - e
] Mantain relative size

Interval Gptios:

e Mumber of lsbeled intervals: Sintmrvalle)

Marrber af hortzontal s

Number of mtervals tn subdhide: 0 interval(s)

Mumber of sub-ntervals: 2 2 4

71 Apply kocale formattng to rumbers (&0, $ousend separatons] in interval labels
Add nterval left of U

Labefing Optioms:

1 Tick bt B dcisimecuie 10,00 0t

Tick lsbel gnacng: 300
§ Show above

(o iDuschay urvts %o right of last intervel lsbel

e || Display scale value:

Deziay page to map urvis rat;

Cumtumuze Labets,..|

Maim Bar Unirsed

= [ 22 o conter

e ]

Carord
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3. Select the scale bar and reduce the size of the bounding box around the object. The horizontal scale can also be
changed this way and will modify the bar increments automatically according to the width.

Scale 1:22,100 Scale 1:22,100

HEm -

0 200 400 600 800 1000 Meters
0 200 400 600 800 1000 Meters

4. Move the scale bar to the lower left corner of the map extent.

0 200 400 @00 800 1,000 Mefers

(=] Aquarium

[iiii Point of Interest
Hotel

£ Information

(1) Restaurant

Ed Science

5. If necessary, save your Adobe lllustrator file.
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9 Export to Web

Continue working with your map or open Vancouver Downtown 9.ai.

9.1 Finalize map

In the Adobe lllustrator Layers panel, select the Legend layer.

2. Using the Type tool, type Vancouver Downtown and move it to the upper right corner of the map. Use a white color
and larger font or choose the Title_Style from the Character Styles panel. Optionally, add a drop shadow to the
text (choose Effect > Stylize > Drop Shadow) to make it stand out.

Vancouver Downtown

3. Selectall art on the Land_area, Parks_area, and Image layers (Ctrl+click on PC and Cmd+click on Mac) using the
target buttons. Open the Transparency panel (choose Window > Transparency) and change the opacity to 75%
for all three layers.

‘

Hotsls_point

Restzurants_point
Roads_line
River_line

Water_area

Parks_area

Land_sres

@9/ @ @06 806068
Yy vy vvovw

1
9@ o oloalo

m oo

VancouverDowntown_image
L m e ow @

b

i

4. Select all art on the Hotels_point, Restaurants_point and PointsOflnterest_point layers and open the MAP Attributes
panel to review the attributes schema of each. Use the Layer drop-down list to switch between selected layers.
Become familiar with the attribute structure before exporting to a Web map.

MAP Attributes

Layer: | 2| Hotels_point (10 points selected) [+]
[SIHOTEL_NAME  |[S]ADDRESS slcmy [SPROVINGE  |[S/TELEPHONE |5 WEBSTTE [S1CATEGORY

1 |Dpus Hotel 322 DavieSt | Vancouver BC (604) B42-6787 hotel

2 [Sunsetinn 5. |1111 Bumaby 5t | Vancouver BC (604) B88-2474  wwwisunsetinn.... hotel

5 |Sandman Hotel... | 130 Georgia St .. | Vancouver BC (604) 681-2211 hotel

4| Pendrell Suites ... | 1419 Pendrell St... | Vancouver BC (604) 609-2770 hotel

5 |Bayshore The... |1601 Bayshore .. | Vancouver BC (604) 6916936 wwwistarwood... | hotel

5 |The Barclay Ho... |1351 Barclay Str.. | Vancouver BC (604) 6051351 wwawbarclayho... | hotel

7 jssance Va.. | 1133 West Hasti.. Vancouver BC (604) 689-9211 i hotel

3 |Sherston Vanco... | 1088 Burrrd Str.. | Vancouver BC (604) 3311000 wwwistarwond... | hotel

5 [Fsimont Hotel | 900 West Georg... Vancouver BC (604)684-3131  wwwifsirmont.... | hotel

10| Coast Plaza Hot.. | 1763 Comox Str.. | Vsncouver BC (800) 716-6199  wwwicoasthote...  hotel

10 points selected B o Be@E /m3EH
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9.2 Using MAP Web Author

The MAP Web Author panel provides access to create and edit web tagged content and export your document to a
web map. First, you'll create callouts for the Hotel points layer, then for the Restaurants and Points of Interest layers.

1. Inthe MAPublisher toolbar, click the MAP Web Author button .
2. From the panel option menu, choose Specify Source Media Folder.

Tag: Export:

‘ Edit H Remove | | Flash H HTML5|

Selection:
Al Web Art| |Web Art On Layer

3. In the Specify Source Media Folder dialog box, select the Relative Path option, browse to the directory
\MAPublisher 9\Quick Start Guide & Data, and click OK.

Specify Source Media Folder

() Absolute path @ Relative path

An empty relative path indicates the same folder 2= the docment,

Note: An empty relative path indicates the same folder as the document.

4. Inthe Adobe Illustrator Layers panel, select all the points on the Hotels_point layer.
5. Inthe MAP Web Author panel, click the Edit button.

MAFP Web Author

Tag: Export:

| Edit H Remove ‘ ‘ Flash || HTMLS |

Selection:
All Web Art| |Web Art On Layer

10 pieces of art selected

MAPublisher 9.1 Quick Start Guide 31
9 Export to Web



6. In the Edit Web Tag dialog box, change the title to <b>%HOTEL_NAME%</b>.

Note: Alternatively, copy the text from the Web Author Formatting.txt file (located in \Quick Start Guide & Data\Quick
Start Data\Additional Files).

The Show Preview option is enabled by default. It displays a preview of the web tag (callout). The Auto Size
option that automatically resizes the callout to fit content is also enabled by default.

7. Type (or copy from Web Author Formatting.txt) the following text content for the callout:

Address: %ADDRESS%<br>

Telephone: %TELEPHONE%<br>

<br>

Visit the <a href="http://%WEBSITE%"">website</a>

This text is comprised of HTML and references to the attribute table for the specific layer. For example, text
between % signs refer to attribute names and <br> indicates a line break. The results of this formatting can be
seen in the Callout Preview window. For more information, refer to chapter 15 of the MAPublisher User Guide.

Edit Web Tag ]
Callout options (7 Flash @ HTMLS
Web Tag Text showprevien [4] /10 ] OpusHotel
i __b Address: 322 Davie St
E] ke Telephone: (604) 642-6787

Tt | s s4HOTEL_NAME%</b>

Visit the website

Content: | aderess: %ADDRESSs<br>

Telephone: %TELEPHONE%, <br>

<br>

Visit the <a href="http://%WEBSITE%: ">website </a>

Enter HTML to be displayed in the callout ttle and content areas,
Web Tag Size Web Tag Image
- [ormeromer] (%]
Height: | 120 px . Use original size:
Auto size
External URL Triggers
Click URL: Target: -

Hover URL: Target: -

The specified URLS) will be opened when the user hovers over or cicks art, Use the target o load
the URL in & spacific heml frame or 2 new window,

Attribute column information may also be added using the <insert attribute> drop-down list in the Web Tag
Dialog dialog box. This essentially adds attributes (e.g. %ADDRESS%) as variable which ensure that any changes
to the information will still populate the Web tags.

8. Make sure the dialog box matches the one above and click OK.
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Now create callouts for the restaurant points layer.

9. Inthe Adobe lllustrator Layers panel, select all the points on the Restaurants_point layer.
10. In the MAP Web Author panel, click the Edit button.
11. In the Edit Web Tag dialog box, change the title to <b>%RESTAURANT%</b>.

12. Type in (or copy from Web Author Formatting.txt) the following text content for the callout:

Speciality: <b>%SPECIALI
<br>
Address: %ADDRESS%<br>

TY%</b><br>

Telephone: %TELEPHONE%<br>
Webpage: <a href="http://%WEBSITE%"">%WEBSITE%</a>

13. Click the Web Tag Image box then click the Insert Attribute drop-down list and click %P 1 CTURE1%.

Note: Images can be added to callouts that are referenced in the attribute table (done in this exercise) or done
manually from any location. Use the preview arrow buttons to rotate through the callouts.

Edit Web Tag

Callout options () Flash @ HTMLS
Web Tag Text

B||r][e]|an] = gji Insert Atiribute

[¥] Show Preview /12 @

Tite: [ b - otRESTAURANT % </b>

Content: | gpeciality: <b>%SPECIALITY %< /b <br>

Address: %ADDRESS %<br
Telephone: %TELEPHONE %6 <br>
Webpage: <a href="htt://WEBSITE %> %WEBSITE %< /2>

Enter HTML o be displzyed in the callout tite 2nd content areas,
Web Tag Size Web Tag Image

Width: | 120 px z HPICTLRE 1% Brawse For Image

Height: | 120 px : [¥] use original size Preview image size: width 200, height 73

Auto size

External URL Triggers
Click URL: Target: -

Hover URL: Target: -
The specfied URL(S) will be opened when the user hovers over o cicks art Use the targe 1o load
the URL in 2 specfic haml frame o 2 new window,

CinCin Ristorante&Bar

Speciality: Italian

Address: 1154 Robson
Telephone: (604)688-7338
Webpage: www.cincin.net

14. Make sure the dialog box matches the one above and click OK.
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Now create callouts for the points of interest point layer.

15. In the Adobe Illustrator Layers panel, select all the points on the PointsOfinterest_point layer.

16. In the MAP Web Author panel, click the Edit button.

17. In the Edit Web Tag dialog box, change the title to <b>%P laceName%</b>.
18. Type in (or copy from Web Author Formatting.txt) the following text content for the callout:

Address: %Address®%<br>
<br>

Telephone: %Telephone%<br>
<br>

Visit our <a href="http://%Web%">webpage</a>

19. Click Web Tag Image Image box, then click the Insert Attribute drop-down list and click %logo__image%.

Edit Web Tag

]

callout options ) Flash @ HTMLS
Web Tag Text
B||Z||e||de =] |E||nsertAttribute

Show Preview E 1/10 @

* | <b>%PlaceName%-</b>

Content: | adaress: %Address%<br>
<br>
Telephone: %&TelephoneSe<br >

r
Visit our <a href="http://%Web%">webpage</a>

Enter HTML to be displayed in the callout tie and content areas,

Web Tag Size Web Tag Image
i [ P
Height: | 120 px Use original size Preview image size: width 86, height 54
Auto size
External URL Triggers
Click URL: Target: -
Hover URL: Target: -
The specfied URLs) will be opensd when the user hovers over or dicks ant, Uss the target 1o boad
the URL in a specific himl frame or 2 new window.

Vancouver Aquarium

r;«* Address: 845 Avison Way
Gauanum
Telephone: (604) 659-3474

Visit our webpage

20. Make sure the dialog box matches the one above and click OK.

21. If necessary, save your Adobe lllustrator file.
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9.3 ExporttoWeb

1. Inthe MAP Web Author panel, under the Export section, click the HTMLS5 button.

| Edit || Remove ‘ | Flash ||}-|'I'ML5|

Selection:

|AII Web Art| Web Art On Layer

2. Beside the Export location box, click the Browse button, navigate to \MAPublisher 9\Quick Start Guide & Data and
create a new folder called Vancouver, type index.html as the file name and click Save.

3. Click the Show/Hide Layers tab and click the Allow users to hide and show layers in the viewer check box to enable

its settings.

4. Click the Add button. Locate the Hotels_point layer and click its check box in the Selected column. Click OK.

Select layers for toggleable layer group.

Layer Name

=

Boundary_area

H Legend

HH Scale Bar
Neighbourhoods Labels
Hotels_point

T| Restaurants_point

7| PointsOflnterest_point
Roads_line

River_line

Selected o

m

1000OoEEEEE

OK.

5. Click the Hotels_point group and change the name to Hotels in the Display Name box.

6. Repeat the process for Restaurants_point and PointsOfInterest_point and change the display name appropriately.

When prompted, create a new group for each layer.

Viewer | Hide/Show Layers | Scale Dependentlayers | Theme | Advanced

Allow the user to hide and show layers in the layers list

E] E] Options

4 Hotels
Pl Hotels_point
4 Restaurants
F| Restaurants_point
4 Points of Interest
7| PointsOfInterest_point

Display Name:  Points of Interest
Tnitially Visible

[7] Do Mot Show In Layer List

Layer List Icon (32x32 pixels or smaller)

Brawse... @
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7. Click the Theme tab and click the Use Custom Theme option. Choose an orange color (C=0, M=80, Y=95, K=0)
from the Feature Highlight drop-down list.

Viewer | Hide/showLayers | Scale Dependentlayers | Theme | Advanced

() Use Light Theme - Black text and lines on & white background.
() Use Dark Theme - White text and lines on a black background.

@ Use Custom Theme:

Cantral Foreground: | [llSeecify colour -

Control Background: | Specify colour
Cantral Highlight: Specify colour

Control Border: [l Specify colour

EE00OE

Feature Highlight: [ C=0 M=80 Y=95K=0

Optionally, click the Viewer Style and Viewer Settings tab to view all the settings and options that can be
potentially changed. However, for this tutorial, leave them at the default settings.

8. Click Export.

Web Export Log

Export Folder: C:\Jsers\Public\Documents'AvenzaMAPublisher 9\Quick Start Guide & DataVancouver << Export Again
2.34 MBs in 41 tiles

77.86 KBs in map data

To reduce exported file sizes and improve map viewer performance:

*Export as few attributes as possible, Only attributes that appear in Web Tags are exported.

* Simplify all artwork for tagged features. Simpler features require less space to spedfy outiines
and highlights appear faster in the viewer.

*Clip all artwork to the artboard.

*Resize the artboard to match the size of the viewport that you intend to export to.

*Use a lower maximum zoom value to limit the number of raster map tiles created.

* Limit the number toggleable layers, A separate set of raster tiles must be created for each layer
that can be toggled.

The Web Export Log dialog box shows the results of the export.

9. Click the Export Folder link at the top of the dialog box to open the file browser.

Folders v | Name B Date modified Type Size
Avenza - index_data 26/10/201210:20 AM  File Folder
Geographic Imager & index.html 26/10/201210:20 AM  Chrome HTML Do... 3KB

MAPublisher 8
Helpful Styles & Symbols
. MAP LabelPre Tuterial Guide & Data
. Quick Start Guide & Data
Quick Start Data
Vancouver
index_data
layer 1 files
! layer_2 files
. layer_3 files
layer_4_files

sourcemedia
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10. Open index.html in a web browser (such as Internet Explorer, Mozilla Firefox or Safari).

v Hotels

v Restaurants

v Points of Interest

Tourism Information Centre

E Address: 200 Burrard Street |

woumim  Telephone: (604) 683-2000
VanNCouver

Visit our webpage

~Scale 122,100
0200 400 800 800 1000 Meter:

2 Aquarium

[ Point of Interest
Hotel
Information

(@) Restaurant
Science Center

Navigate the map using the mouse to pan and the zoom buttons and slider on the left hand side. Click the symbols
to see the web tag callouts that you created. In the layers list, toggle on and off the layers you specified during
export. The overview map can be used to navigate the map when zoomed in to the main map. All of the navigation
tools and surrounding map elements, like the overview map and search box, can be customized further.

Conclusion

Experiment on your own with the MAP Web Author Flash export. For in-depth information on MAP Web Author,
see chapter 15 of the MAPublisher 9.1 User Guide and the MAPublisher 9.1 Tutorial Guide. These documents are
installed with MAPublisher and can also be downloaded from http://www.avenza.com/documentation.

To quickly create a geospatial PDF of the Vancouver downtown map, return to Adobe Illustrator and click the Export
Geospatial PDF button on the MAPublisher toolbar, You can find more information about geospatial PDF in the
chapter 17 of the MAPublisher 9.1 User Guide and MAPublisher 9.1 Tutorial Guide.

Congratulations, you have completed the Quick Start Guide. From here, you can look at more detailed and
advanced exercises in the MAPublisher 9.1 Tutorial Guide, get in-depth information about features and tools in the
MAPublisher 9.1 User Guide and tips and tricks from the Avenza Resources blog and user forum on avenza.com.
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